You need to have the latest version of Appcompanist to accept shares. Please upgrade or install on your device.